CMakeLists.txt
changeset 397 13fa0546ef87
parent 396 e1a24791d192
--- a/CMakeLists.txt	Thu Jan 15 21:33:54 2009 +0200
+++ b/CMakeLists.txt	Fri Jan 16 00:42:02 2009 +0200
@@ -24,11 +24,8 @@
 	set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel." FORCE)
 endif(NOT CMAKE_BUILD_TYPE)
 
-# include cmake stuff
-include ("cmake/FindVersion.cmake")
-
-# Determine PROJECT_VERSION
-FindProjectVersion ("${CMAKE_SOURCE_DIR}")
+# Compile-time version script
+include ("cmake/BuildVersion.cmake")
 
 # skip source code definitions if just building docs
 if (NOT KG_DOC_ONLY)