CMakeLists.txt
changeset 395 91d96387b359
parent 374 1862c5f2cfc3
child 396 e1a24791d192
--- a/CMakeLists.txt	Tue Jan 13 23:54:47 2009 +0200
+++ b/CMakeLists.txt	Thu Jan 15 20:38:23 2009 +0200
@@ -32,7 +32,11 @@
 	set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel." FORCE)
 endif(NOT CMAKE_BUILD_TYPE)
 
-add_subdirectory(src)
-add_subdirectory(data)
+# skip source code definitions if just building docs
+if (NOT KG_DOC_ONLY)
+    add_subdirectory(src)
+    add_subdirectory(data)
+endif (NOT KG_DOC_ONLY)
+
 add_subdirectory(doc)