src/CMakeLists.txt
changeset 67 aa94bf2b5f9b
parent 59 375a3b5c3a46
child 68 591a574f390e
--- a/src/CMakeLists.txt	Mon Mar 16 01:14:36 2009 +0200
+++ b/src/CMakeLists.txt	Mon Mar 16 20:22:51 2009 +0200
@@ -1,9 +1,11 @@
 # dependancies
 find_package (LibEvent REQUIRED)
 find_package (GnuTLS REQUIRED)
+find_package (LibPQ REQUIRED)
+find_package (Evsql REQUIRED)
 
 # add our include path
-include_directories (${LibEvent_INCLUDE_DIRS} ${GnuTLS_INCLUDE_DIRS})
+include_directories (${LibEvent_INCLUDE_DIRS} ${GnuTLS_INCLUDE_DIRS} ${Evsql_INCLUDE_DIRS})
 
 # define our source code modules
 set (CORE_SOURCES error.c log.c)
@@ -31,6 +33,7 @@
 # set libraries
 target_link_libraries (nexus ${NEXUS_LIBRARIES})
 target_link_libraries (test ${NEXUS_LIBRARIES})
+target_link_libraries (irc_log ${Evsql_LIBRARIES})
 
 # global target properties
 set_target_properties (nexus test irc_log PROPERTIES
@@ -44,6 +47,7 @@
 
 # modules have weird names
 set_target_properties (irc_log PROPERTIES
+    PREFIX                      "mod_"
     LIBRARY_OUTPUT_DIRECTORY    "modules"
 )