os/debian/rules
author matthijs
Wed, 03 Sep 2008 17:18:04 +0000
changeset 10070 8970f1074f21
parent 10069 891d75deeb73
child 10098 de9c1bd521c8
permissions -rwxr-xr-x
(svn r14238) -Change [Debian]: Update Debian packaging files to the latest official Debian version.
- Packaging files are now identical to those of the official 0.6.2-1 (or,
r11138 in the collab-maint subversion repository), with the following
exceptions:
- Desktop files are removed, since openttd trunk installs them already.
- Changes regarding package names from r14237 are preserved.
- Topmost changelog entry with version 0.7~svn-1 is added.
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

DEFAULT_PACKAGE := openttd
# Find the package name from the topmost changelog entry.
# Is this the best way to do this?
PACKAGE = $(shell cat debian/changelog | head -1 | cut -f1 -d' ')

debian/control:
	# Generate control file
	sed 's/PACKAGE/$(PACKAGE)/' debian/control.in > debian/control

	# TODO: How to do this using makefile conditionals?
	if [ "$(PACKAGE)" != "$(DEFAULT_PACKAGE)" ]; then \
		echo "Provides: $(DEFAULT_PACKAGE)" >> debian/control ; \
		echo "Conflicts: $(DEFAULT_PACKAGE)" >> debian/control ; \
	fi;

configure: debian/control configure-stamp
configure-stamp:
	dh_testdir
	# Add here commands to configure the package.

	touch configure-stamp


build: debian/control configure build-stamp
build-stamp:
	dh_testdir

	# Add here commands to compile the package.
	
	./configure --prefix-dir=/usr --binary-dir=games --data-dir=share/games/openttd --icon-dir=share/pixmaps --personal-dir=.openttd --install-dir=debian/$(PACKAGE)
	$(MAKE)

	#/usr/bin/docbook-to-man debian/openttd.sgml > openttd.1

	touch build-stamp

clean: debian/control
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp

	# Add here commands to clean up after the build process.
	# We check for Makefile presence, because clean is called at the
	# start of the build process (before configure) where we don't
	# have a Makefile yet.
	[ ! -f Makefile ] || $(MAKE) distclean

	dh_clean
	# Clean up generated control file
	-rm debian/control

install: debian/control build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs

	# Add here commands to install the package into debian/openttd.
	$(MAKE) install

# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.

# Build architecture-dependent files here.
binary-arch: debian/control build install
	dh_testdir
	dh_testroot
	dh_installchangelogs changelog.txt
	dh_installdocs
	dh_installexamples
#	dh_install
	dh_installmenu
	dh_installdebconf
#	dh_installlogrotate
#	dh_installemacsen
#	dh_installpam
#	dh_installmime
#	dh_installinit
#	dh_installcron
#	dh_installinfo
	dh_installman docs/openttd.6
	dh_link
	dh_strip
	dh_compress
	dh_fixperms
#	dh_perl
#	dh_python
#	dh_makeshlibs
	dh_installdeb
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure