Sun, 06 Aug 2006 16:32:49 +0000 tron (svn r5794) Pass the TileIndex plus x and y coordinates into GetSlopeZ_* instead of a TileInfo
Sun, 06 Aug 2006 08:23:19 +0000 tron (svn r5787) Rename width, height and unk of struct DrawTileSeqStruct to size_{x,y,z}
Sun, 06 Aug 2006 01:51:57 +0000 belugas (svn r5785) Fix(5771) : Silenced a warning in MSVC that prevented from compiling.
Sat, 05 Aug 2006 21:59:07 +0000 miham (svn r5782) [Translations] Added initial japanese translation
Sat, 05 Aug 2006 17:00:09 +0000 tron (svn r5773) Clarify why the owner is checked before a palette is chosen when drawing a station tile: some stations are not owned by players
Sat, 05 Aug 2006 16:57:39 +0000 tron (svn r5772) Road depots always have an player as owner, so remove an useless check
Sat, 05 Aug 2006 16:54:55 +0000 tron (svn r5771) Unify several code paths and data structures for drawing train depots and waypoints
Sat, 05 Aug 2006 10:30:43 +0000 Darkvater (svn r5769) - Fix (r5762): fix some mistakes in the opendir code and filesize calculation. Thanks to Tron for noticing (and fixing).
Sat, 05 Aug 2006 00:59:45 +0000 Darkvater (svn r5767) - Cleanup: Improve upon the header file mess regarding fios. Move all relevant types from hal.h into fios.h, eliminate the unneccessary passing of a global variable, and extern variables in header files (declare in fios.c and misc_gui.c
Sat, 05 Aug 2006 00:53:09 +0000 Darkvater (svn r5766) - Cleanup: Unify FiosBrowseTo and FiosGetDescText
Sat, 05 Aug 2006 00:47:32 +0000 Darkvater (svn r5765) - Codechange: Fully unify the OS-specific FiosGet...List functions into fios.c, as well as FiosGetSavegameList and FiosGetScenarioList functions with the help of some callbacks.
Sat, 05 Aug 2006 00:16:24 +0000 Darkvater (svn r5764) - Cleanup: - Cleanup: Move the now unified FiosAlloc, compare_FiosItems, FiosFreeSavegameList, FiosMakeSavegameName, FiosDelete and FileExists to newly created file fios.c where it belongs.
Fri, 04 Aug 2006 23:45:20 +0000 Darkvater (svn r5763) - Cleanup: Move the now unified GetLanguageList and comparator function to strings.c where it belongs.
Fri, 04 Aug 2006 23:41:13 +0000 Darkvater (svn r5762) - Codechange: Implementation of POSIX-style opendir/readdir/closedir functions for windows using FindFirstFile/FindNextFile/FindClose.
Fri, 04 Aug 2006 23:33:05 +0000 Darkvater (svn r5761) - Cleanup: Really minor whitespace changes, and remove an extern from a function decleration in header file.
Fri, 04 Aug 2006 23:27:36 +0000 Darkvater (svn r5760) - Codechange: Use a define for case-string comparison in OS/2 instead of function.
Fri, 04 Aug 2006 22:26:44 +0000 bjarni (svn r5759) -Fix: [OSX] fixed issue where the bundle was not build if the data dir contained subdirs (now copies the subdirs as well)
Fri, 04 Aug 2006 05:52:10 +0000 miham (svn r5750) WebTranslator2 update to 2006-08-04 07:51:51
Thu, 03 Aug 2006 18:09:42 +0000 miham (svn r5742) WebTranslator2 update to 2006-08-03 20:09:26
Thu, 03 Aug 2006 06:44:54 +0000 tron (svn r5723) - Move the declaration of DrawRoadDepotSprite() out of functions.h (but I'm not too happy with the new header)
Wed, 02 Aug 2006 18:36:53 +0000 miham (svn r5714) Backport from branches/TGP (r5701 and r5711)
Tue, 01 Aug 2006 19:24:29 +0000 Darkvater (svn r5698) - Fix [r5697]: don't remove ctype include for win32.c; needed for toupper...ugh
Tue, 01 Aug 2006 19:19:39 +0000 Darkvater (svn r5697) -Fix [r5684]: tolower() was undefined for certain architectures, strangly VS2003 didn't complain, VS2005 did. Thanks glx
Tue, 01 Aug 2006 17:56:39 +0000 miham (svn r5696) WebTranslator2 update to 2006-08-01 19:56:23
Tue, 01 Aug 2006 13:27:26 +0000 miham (svn r5692) WebTranslator2 update to 2006-08-01 15:27:09
Tue, 01 Aug 2006 06:08:11 +0000 tron (svn r5690) Factor common code to reduce code duplication
Tue, 01 Aug 2006 06:04:50 +0000 tron (svn r5689) Default a station tile to be electrifiable if there is no other information available. I suppose this was a copy&paste error
Mon, 31 Jul 2006 22:40:55 +0000 Darkvater (svn r5688) - Forward-port the release-changes from the 0.4 branch back to trunk. This ensures an updated changelog, known-bugs, etc.
Mon, 31 Jul 2006 22:26:11 +0000 Darkvater (svn r5687) - Cleanup: Some cleanup and commentarizing.
Mon, 31 Jul 2006 22:24:09 +0000 Darkvater (svn r5686) - Codechange: Use only FioFOpenFile for opening files, use the other similar functions (FioCheckFileExists and FioOpenFile) as its caller.
Mon, 31 Jul 2006 22:15:39 +0000 Darkvater (svn r5685) - Codechange: s/FiosCheckFileExists/FioCheckFileExists/ to unify the naming of these functions.
Mon, 31 Jul 2006 22:11:34 +0000 Darkvater (svn r5684) - Codechange: create an strtolower() function that uses tolower() on a whole string and apply it in the places this was used.
Mon, 31 Jul 2006 11:52:39 +0000 Darkvater (svn r5670) - The keyword is $Id$ not $Id :)
Sun, 30 Jul 2006 22:55:17 +0000 Darkvater (svn r5665) - Codechange: check pointers against NULL, coding style, tabulation; nothing serious.
Sun, 30 Jul 2006 22:43:50 +0000 bjarni (svn r5664) -Fix: [SF 1518090 ] moving train engines in depot - crash (svn r5463)
Sun, 30 Jul 2006 14:58:17 +0000 Darkvater (svn r5656) -Fix [SF 1296259]: Autosave override. Changing autosave interval ingame should also change the default interval.
Sun, 30 Jul 2006 14:57:28 +0000 Darkvater (svn r5655) -Fix [SF 1424115]: Reversed arrow-sign in the multiplayer list column headers on sort by name
Sun, 30 Jul 2006 14:56:40 +0000 Darkvater (svn r5654) -Cleanup: Change an ugly define into a function
Sun, 30 Jul 2006 14:55:25 +0000 Darkvater (svn r5653) -Cleanup: Do a little cleanup of the industry gui code.
Sun, 30 Jul 2006 14:53:59 +0000 Darkvater (svn r5652) -Fix [SF 1480301]: Industry production change button doesn't work
Sun, 30 Jul 2006 07:42:37 +0000 tron (svn r5641) -Fix: Adjust/correct some bounding boxes. This fixes some graphical glitches near bridges
Sat, 29 Jul 2006 17:39:58 +0000 tron (svn r5632) Replace a boolean variable in DeallocateSpecFromStation() by a return
Sat, 29 Jul 2006 13:06:00 +0000 tron (svn r5631) Don't allocate memory for information about a sprite which isn't drawn
Sat, 29 Jul 2006 11:15:34 +0000 tron (svn r5630) Replace a boolean variable by continue
Sat, 29 Jul 2006 10:18:59 +0000 tron (svn r5629) Simplify the test whether two bounding boxes overlap
Sat, 29 Jul 2006 06:39:19 +0000 tron (svn r5628) Rename the attributes for the bounding box of struct ParentSpriteToDraw to something sensible. Half of them was totally off: right is left, bottom is top *sigh*
Fri, 28 Jul 2006 22:01:43 +0000 belugas (svn r5627) Fix (r5626) : Forgot to rename one instance make_screenshot to current_screenshot_type
Fri, 28 Jul 2006 21:51:00 +0000 belugas (svn r5626) CodeChange : Remove the global _make_screenshot and implement a more flexible mechanism
Thu, 27 Jul 2006 14:07:51 +0000 miham (svn r5625) WebTranslator2 update to 2006-07-27 16:07:36
Thu, 27 Jul 2006 05:30:53 +0000 tron (svn r5624) Use {IsPlainRailTile,IsRailDepot,IsRailWaypoint,HasSignals}() instead of GetRailTile{T,Subt}ype() - this is more concise and a bit more flexible if/when the rail tile encoding changes
Wed, 26 Jul 2006 19:07:19 +0000 miham (svn r5623) WebTranslator2 update to 2006-07-26 21:07:04
Wed, 26 Jul 2006 12:11:52 +0000 tron (svn r5618) Remove a redundant check, CheckTrackCombination() a few lines above performs the same test
Wed, 26 Jul 2006 10:50:46 +0000 tron (svn r5617) if cascade -> switch
Wed, 26 Jul 2006 10:31:23 +0000 miham (svn r5616) WebTranslator2 update to 2006-07-26 12:31:09
Wed, 26 Jul 2006 10:00:33 +0000 tron (svn r5615) Move GetStationTileForVehicle() to its only user
Wed, 26 Jul 2006 08:41:14 +0000 tron (svn r5614) Move a type declaration to its only user
Wed, 26 Jul 2006 08:32:20 +0000 tron (svn r5613) Rename VS_DISASTER to VS_SHADOW, because this is what this flag actually means
Wed, 26 Jul 2006 08:27:05 +0000 tron (svn r5612) Restructure some code which uses the vehicle position hash to make it a bit clearer what's going on
Wed, 26 Jul 2006 05:58:34 +0000 tron (svn r5611) Remove a stale comment
Wed, 26 Jul 2006 05:57:30 +0000 tron (svn r5610) Remove a pointless call to VehicleInTheWayErrMsg() - only trains can be on rail bridges