tunnelbridge_cmd.c
Tue, 09 May 2006 08:25:31 +0000 rubidium (svn r4789) - Codechange: rename RoadType to RoadTileType and ROAD_{NORMAL,CROSSING,DEPOT} to ROAD_TILE_* for consistency
Tue, 09 May 2006 08:17:33 +0000 rubidium (svn r4788) - Codechange: RAILTYPE_{NORMAL,ELECTRIC,...} and RAIL_TYPE_{NORMAL,SIGNAL,...} have nearly the same name, rename RAIL_TYPE_* to RAIL_TILE_* of extra clarity
Sun, 07 May 2006 11:55:28 +0000 tron (svn r4771) -Regression: It was possible to remove a bridge while a vehicle was on it
Sun, 07 May 2006 08:18:12 +0000 tron (svn r4766) -Fix: Vehicles on a sloped tile under a bridge were affected by the bridge speed limit
Sun, 07 May 2006 07:55:05 +0000 tron (svn r4765) Add GetTileMaxZ(), which returns the height of the highest corner of a tile, and use it to simplify the code in a few places
Tue, 25 Apr 2006 07:32:33 +0000 tron (svn r4572) Remove vehicle_leave_tile_proc
Sun, 23 Apr 2006 19:35:36 +0000 tron (svn r4554) Replace magic numbers by TILE_{HEIGHT,SIZE}
Sun, 23 Apr 2006 13:48:16 +0000 tron (svn r4541) Add a type for slopes and replace many magic numbers by the appropriate enums
Sat, 15 Apr 2006 16:07:00 +0000 Darkvater (svn r4430) - NewGRF: Use the bridge's sprite layout for drawing high pillars. This fixes newgrf's high-bridge pillars drawing. Also remove the now obsolete _bridge_poles_table which was already integrated into the bridge sprite tables
Wed, 12 Apr 2006 19:05:31 +0000 tron (svn r4402) Fix a faulty entry in the table for slopes under bridges, remove a now unnecessary test which hid the faulty entry till now and undo r4398 (don't do this!)
Wed, 12 Apr 2006 17:58:58 +0000 celestar (svn r4398) -Fix: Quick and Dirty solution for FS#116. Just for the nightlies
Wed, 12 Apr 2006 15:23:32 +0000 celestar (svn r4392) -Codechange: Use water map accessors in bridge code
Wed, 12 Apr 2006 15:21:33 +0000 celestar (svn r4391) -Fix: faulty ")" in previous commit
Wed, 12 Apr 2006 15:08:48 +0000 celestar (svn r4390) -Codechange: Upon merging elrails, one direct map access to the railtype went unnoticed...
Wed, 12 Apr 2006 05:26:36 +0000 tron (svn r4374) Never directly commit something you prepared the evening before, mysteriously it will break in the morning, fix r4373
Wed, 12 Apr 2006 05:19:19 +0000 tron (svn r4373) Rewrite GetSlopeZ_TunnelBridge() and slightly change its behavior:
Mon, 10 Apr 2006 12:36:04 +0000 tron (svn r4344) Use tile coordinates or even TileIndices instead of virtual tile coordinates where it suffices.
Mon, 10 Apr 2006 07:15:58 +0000 tron (svn r4342) Change the first two parameters of commands - virtual pixel coordinates of the tile to operate on - to a TileIndex
Mon, 03 Apr 2006 18:11:42 +0000 Darkvater (svn r4265) - Fix: compile warning on VS2005 (parameter 2 different from declaration)
Mon, 03 Apr 2006 09:07:21 +0000 celestar (svn r4249) -Codechange: Replace more occurences of 16 by TILE_SIZE and of 8 by TILE_HEIGHT. Reverted one change from the previous commit because it was faulty
Sun, 02 Apr 2006 12:49:18 +0000 tron (svn r4242) Pass TileIndex and slope to GetSlopeTileh_*() instead of TileInfo
Thu, 30 Mar 2006 19:16:44 +0000 belugas (svn r4181) CodeChange : Replaced [G/S]etMapExtraBits by [G/S]etTropicZone. Although it was an accessor, nor his usage nor the values were clear.
Thu, 30 Mar 2006 09:08:43 +0000 tron (svn r4164) Use acessor functions
Wed, 29 Mar 2006 20:35:39 +0000 belugas (svn r4157) CodeChange : Keep on cleaning up Celestar's elrail merge
Wed, 29 Mar 2006 16:30:26 +0000 celestar (svn r4150) -Feature: Merged elrails into trunk. Thanks to Tron for lots of code and proofreading, thanks to peter1138 for another lot of code and ideas.
Thu, 23 Mar 2006 06:30:39 +0000 tron (svn r4047) Remove two calls to FindLandscapeHeight() and some confusing use of the comma operator
Sun, 19 Mar 2006 12:06:12 +0000 tron (svn r3979) Move GetRailFoundation() to rail_map.h and use it and friends to get information about rail tiles
Fri, 17 Mar 2006 13:28:50 +0000 tron (svn r3922) Fix copy&pasto in r3916 (Slowly it's getting a bad habit)
Fri, 17 Mar 2006 10:10:31 +0000 tron (svn r3916) Get/Set the rail type by [GS]etRailType{Crossing,OnBridge,}()
Thu, 16 Mar 2006 15:16:27 +0000 tron (svn r3907) Replace many bridge related direct map accesses with calls to shiny new functions and mark some strange constructs with XXX
Thu, 16 Mar 2006 13:35:35 +0000 tron (svn r3906) Before removing a rail/setting the owner of a road to none check if there's a transport route at all under the bridge
Thu, 16 Mar 2006 10:00:50 +0000 tron (svn r3904) Move GetBridgePiece() and GetBridgeType() to bridge_map.h and make the only place which still extracted that info diretly use the wrapper
Thu, 16 Mar 2006 07:18:38 +0000 tron (svn r3903) Fix a copy&pasto in last commit and remove a redundant comment (the line above already says what's going on)
Thu, 16 Mar 2006 07:12:28 +0000 tron (svn r3902) When drawing a bridge middle part get the bridge axis only once instead of again and again
Thu, 16 Mar 2006 06:38:51 +0000 tron (svn r3901) Remove the last user of FindEdgesOfBridge() by using functions with similar functionality
Thu, 16 Mar 2006 06:30:47 +0000 tron (svn r3900) When clearing a bridge determine the bridge direction and tile offset once instead of all over the place; also use UpdateSignalsOnSegment() instead of SetSignalsOnBothDir(), because this is sufficient
Thu, 16 Mar 2006 06:06:05 +0000 tron (svn r3899) Use wrapper functions to make more clear how deleting stuff under bridges works; also remove an unnecessary local variable
Thu, 16 Mar 2006 05:28:15 +0000 tron (svn r3898) Add functions to find a bridge end starting at a middle tile
Wed, 15 Mar 2006 21:27:19 +0000 Darkvater (svn r3893) - Fix: Properly set back the owner of a crossing/road-under bridge after removing it. For crossings we can always use .m2 because it is already 0 when not owned by a town.
Wed, 15 Mar 2006 19:53:25 +0000 tron (svn r3891) Fix r3885
Wed, 15 Mar 2006 17:38:00 +0000 tron (svn r3890) Simplify deleting a bridge by handling the ramps outside of the removal loop
Wed, 15 Mar 2006 17:27:15 +0000 tron (svn r3889) Change a part of the bridge drawing code to make it more comprehensible and add the needed accessors
Wed, 15 Mar 2006 16:47:35 +0000 tron (svn r3888) If you think you've checked everything, check once more. *sigh* Fix r3887
Wed, 15 Mar 2006 16:44:50 +0000 tron (svn r3887) Add a function to get the other bridge end when you're at a bridge ramp
Wed, 15 Mar 2006 16:09:23 +0000 tron (svn r3885) Simplify DoConvertTunnelBridgeRail() a bit
Wed, 15 Mar 2006 07:10:41 +0000 tron (svn r3877) Add functions to turn a tile into a rail/road bridge ramp/middle part
Tue, 14 Mar 2006 12:00:11 +0000 tron (svn r3857) Add and use GetBridgeRampDirection()
Mon, 13 Mar 2006 15:38:52 +0000 tron (svn r3849) Fix bug in r3846
Mon, 13 Mar 2006 12:55:20 +0000 tron (svn r3846) Add functions to set the type of stuff (clear, water, rail, road) under bridges
Mon, 13 Mar 2006 07:12:49 +0000 tron (svn r3838) Demystify building bridge middle parts a bit by removing some magic numbers and generic names
Sun, 12 Mar 2006 20:59:56 +0000 tron (svn r3837) Partially unmagicfy restoring the tiles when deleting a bridge
Sun, 12 Mar 2006 15:04:03 +0000 tron (svn r3830) Move IsTunnelTile() from tile.h to tunnel_map.h and add IsTunnel(), which just checks for a tunnel, but not the tile type as IsTunnelTile() does
Sun, 12 Mar 2006 12:19:25 +0000 tron (svn r3829) Reduce the use of _error_message by directly returning error codes instead of using this global variable
Sun, 12 Mar 2006 08:47:18 +0000 tron (svn r3823) Remove dead code: A value for 'image' gets calculated and overwritten just a few lines later without being used in between
Sat, 11 Mar 2006 17:06:16 +0000 tron (svn r3820) Be a bit more strict with types: use special types instead of generic byte and don't fill arbitrary data into inappropriate types
Fri, 10 Mar 2006 17:01:51 +0000 tron (svn r3814) Remove another call to FindLandscapeHeight()
Thu, 09 Mar 2006 12:32:25 +0000 tron (svn r3803) Change the second parameter of UpdateSignalsOnSegment() from Direction to DiagDirection as that's what it really operates on
Wed, 08 Mar 2006 06:55:33 +0000 tron (svn r3783) Replace further ints and magic numbers by Direction, DiagDirection and friends
Tue, 07 Mar 2006 07:51:05 +0000 tron (svn r3779) Move CheckTunnelInWay() to a more appropriate place, invert its result and give it a less ambiguous name (IsTunnelInWay)
Mon, 06 Mar 2006 20:55:24 +0000 tron (svn r3777) Add some functions to handle tunnels