rail_map.h
Mon, 19 Jun 2006 09:15:16 +0000 tron (svn r5313) Move IsRailWaypoint() to rail_map.h and remove unused enum
Sun, 18 Jun 2006 15:28:29 +0000 tron (svn r5309) Partially fix the rail header dependency fiasco: rail_map.h now depends on rail.h and not the other way round anymore
Wed, 07 Jun 2006 19:35:21 +0000 tron (svn r5155) - Remove the bridge branch merge (revision r5070)
Fri, 02 Jun 2006 13:05:41 +0000 celestar (svn r5070) Merged the bridge branch
Sat, 27 May 2006 16:12:16 +0000 KUDr (svn r4987) Feature: Merged YAPF into trunk. Thanks to devs for continuous support and users for testing.
Tue, 09 May 2006 08:17:33 +0000 rubidium (svn r4788) - Codechange: RAILTYPE_{NORMAL,ELECTRIC,...} and RAIL_TYPE_{NORMAL,SIGNAL,...} have nearly the same name, rename RAIL_TYPE_* to RAIL_TILE_* of extra clarity
Sun, 07 May 2006 07:01:48 +0000 tron (svn r4764) Move some functions from rail.h to rail_map.h
Mon, 17 Apr 2006 19:09:30 +0000 celestar (svn r4461) -Codechange: Add and make use of map accessor functions for signal drawing. Includes some basic cleanup of the drawing functions
Wed, 12 Apr 2006 13:25:32 +0000 celestar (svn r4386) -Codechange: Add and make use of IsCustomWaypoint
Wed, 12 Apr 2006 12:50:40 +0000 celestar (svn r4384) -Codechange: rail drawing code
Wed, 12 Apr 2006 11:58:07 +0000 celestar (svn r4379) -Codechange: Add and make use of map accessor functions concerning rail ground types
Wed, 12 Apr 2006 09:36:27 +0000 celestar (svn r4378) -Add and make use of an accessor function two-way => one-way => one-way => two-way signal cycling
Wed, 12 Apr 2006 09:12:33 +0000 celestar (svn r4377) -Add and make use of a function that finds out whether a signal is an entry or and exit signal to a presignal block (as combos act as both)
Wed, 05 Apr 2006 10:19:59 +0000 celestar (svn r4286) -Fix: Typo in 4280
Wed, 05 Apr 2006 05:22:42 +0000 celestar (svn r4280) -Codechange: Add and make use of map accessors concerning railway waypoints
Wed, 29 Mar 2006 16:30:26 +0000 celestar (svn r4150) -Feature: Merged elrails into trunk. Thanks to Tron for lots of code and proofreading, thanks to peter1138 for another lot of code and ideas.
Sun, 19 Mar 2006 17:52:02 +0000 tron (svn r3985) Make CmdBuildSingleRail() a bit more comprehensible
Sun, 19 Mar 2006 12:06:12 +0000 tron (svn r3979) Move GetRailFoundation() to rail_map.h and use it and friends to get information about rail tiles
Sat, 18 Mar 2006 13:20:50 +0000 tron (svn r3946) Add short hand names for common track combinations
Fri, 17 Mar 2006 10:10:31 +0000 tron (svn r3916) Get/Set the rail type by [GS]etRailType{Crossing,OnBridge,}()
Fri, 17 Mar 2006 07:02:34 +0000 tron (svn r3913) Move declarations to rail_map.h so rail.h is dependent on rail_map.h and not the other way round
Fri, 17 Mar 2006 06:26:37 +0000 tron (svn r3912) Move the signal type enum and GetSignalType() to rail_map.h; also add SetSignalType() and use the functions
Thu, 16 Mar 2006 21:44:58 +0000 tron (svn r3911) Add functions to retrieve/set the signal variant (electric/semaphore)
Sun, 12 Mar 2006 16:13:16 +0000 tron (svn r3831) Add and use GetRailDepotDirection()
Wed, 01 Mar 2006 09:40:34 +0000 tron (svn r3697) Rename DIAG1/DIAG2 to X resp. Y as this conveys a bit better in which direction a pieces of rail goes
Wed, 01 Mar 2006 08:56:38 +0000 tron (svn r3696) Add functions to turn a tile into a normal rail tile/depot/waypoint. This is just a tiny step, the rail code needs way more love and caring