setup.py
changeset 438 d45fc43c6073
parent 437 5100b359906c
child 440 1d755df7bf97
--- a/setup.py	Tue Feb 24 12:47:09 2015 +0200
+++ b/setup.py	Tue Feb 24 14:50:31 2015 +0200
@@ -14,16 +14,16 @@
 
 # TODO: fix to use PEP-396 once available:
 #   https://www.python.org/dev/peps/pep-0396/#classic-distutils
-for line in open('pvl/verkko/__init__.py'):
+for line in open('pvl/hosts.py'):
     if '__version__' in line:
         _, line_version = line.split('=')
         __version__ = line_version.strip().strip("''")
 
 setup(
-    name            = 'pvl-verkko',
+    name            = 'pvl-hosts',
     version         = __version__,
-    description     = "verkko.paivola.fi WSGI",
-    url             = 'http://verkko.paivola.fi/hg/pvl-verkko',
+    description     = "DNS/DHCP hosts management",
+    url             = 'http://verkko.paivola.fi/hg/pvl-hosts',
 
     author          = "Tero Marttila",
     author_email    = "terom@paivola.fi",
@@ -34,39 +34,37 @@
         # pvl.invoke
         'pvl-common',
 
-        # pvl.hosts-import
-        'pvl-ldap',
-        
-        # pvl.verkko.db ->
-        'sqlalchemy',
-
         # pvl.hosts
+        # TODO: replace with ipaddress for py3 forward-compat
         'ipaddr',
     ],
+    extras_require = {
+        # pvl.hosts-import
+        'import': [
+            'pvl-ldap',
+        ],
+
+        # pvl.dhcp-leases/syslog
+        'db': [
+            'sqlalchemy',
+        ],
+    },
     
-    # lib
+    # pvl/
     namespace_packages = [ 'pvl' ],
     py_modules = [
         'pvl.hosts',
     ],
     packages    = [
-        'pvl',
-        'pvl.web',
         'pvl.dhcp',
         'pvl.dns',
-        'pvl.rrd',
-        'pvl.verkko',
     ],
     
-    # bin
-    scripts     = globs('bin/pvl.*-*'),
-    
-    # etc, static
-    data_files  = [
-        ( 'etc/pvl/verkko', [  ] ),
-        ( 'share/pvl/verkko/static/dhcp',   globs('static/dhcp/*.css', 'static/dhcp/*.js')),
-        ( 'share/pvl/verkko/static/rrd',    globs('static/rrd/*.css', 'static/rrd/*.js')),
-        ( 'share/pvl/verkko/static',        globs('static/*.css')),
-    ],
+    # bin/
+    scripts     = globs(
+        'bin/pvl.dhcp-*',
+        'bin/pvl.dns-*',
+        'bin/pvl.hosts-*',
+   ),
 )