rail_cmd.c
Mon, 28 Aug 2006 18:53:03 +0000 rubidium (svn r6204) -Cleanup: replace non-indentation with spaces; like '}<TAB>else {' -> '} else {', tabs between code and comment, etc.
Sat, 26 Aug 2006 14:44:55 +0000 truelight (svn r6141) -Codechange: introduced DepotID and used it as much as possible
Tue, 22 Aug 2006 14:38:37 +0000 rubidium (svn r6045) -Cleanup: align all table-like structures using spaces, i.e. whitespace fixes only except for a few comments to make them uniform for the whole enum/struct.
Sat, 12 Aug 2006 12:56:45 +0000 tron (svn r5864) -Feature: Also allow horizontal and vertical rails on steep slopes
Thu, 10 Aug 2006 14:44:32 +0000 tron (svn r5833) -Feature: Allow building of (certain) rails, roads and bridge ramps on steep sloped tiles
Sun, 06 Aug 2006 16:32:49 +0000 tron (svn r5794) Pass the TileIndex plus x and y coordinates into GetSlopeZ_* instead of a TileInfo
Sun, 06 Aug 2006 08:23:19 +0000 tron (svn r5787) Rename width, height and unk of struct DrawTileSeqStruct to size_{x,y,z}
Sat, 05 Aug 2006 16:54:55 +0000 tron (svn r5771) Unify several code paths and data structures for drawing train depots and waypoints
Thu, 27 Jul 2006 05:30:53 +0000 tron (svn r5624) Use {IsPlainRailTile,IsRailDepot,IsRailWaypoint,HasSignals}() instead of GetRailTile{T,Subt}ype() - this is more concise and a bit more flexible if/when the rail tile encoding changes
Wed, 26 Jul 2006 12:11:52 +0000 tron (svn r5618) Remove a redundant check, CheckTrackCombination() a few lines above performs the same test
Sat, 22 Jul 2006 08:59:52 +0000 tron (svn r5582) Add and use AxisToTrack{Bits,}()
Sat, 15 Jul 2006 09:29:39 +0000 tron (svn r5500) Undo r4597, because it breaks the intended change of r5315 to prohibit building rails on a road tile while road works are in progress
Fri, 14 Jul 2006 18:14:08 +0000 truelight (svn r5497) -Fix: somehow in r5315 slipped some wrong logic, allowed you to build rail on all road pieces without really building it ;)
Wed, 28 Jun 2006 06:10:20 +0000 tron (svn r5396) - Remove two fixed parameters
Tue, 27 Jun 2006 21:25:53 +0000 tron (svn r5391) Miscellaneous, mostly bracing and whitespace, nothing spectacular
Sun, 25 Jun 2006 17:39:19 +0000 tron (svn r5363) Revert 5312, 5288, 5248, 3992, 3249, 3228
Wed, 21 Jun 2006 11:30:28 +0000 tron (svn r5326) Remove the indicator bit for custom waypoint graphics, because it just contains redundant information
Mon, 19 Jun 2006 17:22:57 +0000 tron (svn r5315) -Fix: Prohibit altering a road tile while road works are in progress
Sun, 18 Jun 2006 09:37:08 +0000 tron (svn r5308) Replace an array of function pointers with a switch: It's shorter, more comprehensible, less dependent on magic numbers
Sat, 10 Jun 2006 08:37:41 +0000 tron (svn r5210) Many small changes which piled up: const, unsigned, variable scope, CSE for readability, DeMorgan, if cascades -> switch, whitespace, parentheses, bracing, misc.
Wed, 07 Jun 2006 19:35:21 +0000 tron (svn r5155) - Remove the bridge branch merge (revision r5070)
Fri, 02 Jun 2006 13:05:41 +0000 celestar (svn r5070) Merged the bridge branch
Sat, 27 May 2006 16:12:16 +0000 KUDr (svn r4987) Feature: Merged YAPF into trunk. Thanks to devs for continuous support and users for testing.
Sun, 21 May 2006 13:51:36 +0000 tron (svn r4940) Remove the dubious feature of remembering the last built depot. It serves no real purpose except causing confusion
Sun, 21 May 2006 11:34:08 +0000 tron (svn r4937) Reduce the use of _error_message a bit
Sat, 20 May 2006 18:03:22 +0000 tron (svn r4927) Replace 3 big ifs (which regard foundations) by a bit less confusing code
Thu, 18 May 2006 16:51:42 +0000 glx (svn r4906) - Fix: Refresh build vehicle window (if opened) when converting rail depot
Tue, 09 May 2006 09:56:09 +0000 tron (svn r4790) Remove slope magic from EnsureNoVehicleZ() and rename it to EnsureNoVehicleOnGround() to make more clear what it does
Tue, 09 May 2006 08:25:31 +0000 rubidium (svn r4789) - Codechange: rename RoadType to RoadTileType and ROAD_{NORMAL,CROSSING,DEPOT} to ROAD_TILE_* for consistency
Tue, 09 May 2006 08:17:33 +0000 rubidium (svn r4788) - Codechange: RAILTYPE_{NORMAL,ELECTRIC,...} and RAIL_TYPE_{NORMAL,SIGNAL,...} have nearly the same name, rename RAIL_TYPE_* to RAIL_TILE_* of extra clarity
Sun, 07 May 2006 11:49:48 +0000 peter1138 (svn r4770) - Revert unindented change to rail_cmd.c in r4769.
Sun, 07 May 2006 11:41:44 +0000 peter1138 (svn r4769) - Newstations: add newstations ttdpatch flag
Sun, 07 May 2006 10:58:53 +0000 peter1138 (svn r4767) - Newstations: fix loading / use of custom ground sprites
Sat, 06 May 2006 20:33:22 +0000 peter1138 (svn r4754) - Newstations: expose default station display data via a function so we can use it (rarely) in other places.
Sat, 06 May 2006 09:40:12 +0000 peter1138 (svn r4748) - Newstations: use custom sprite layout callback for waypoints as well as stations. Supports merging of adjacent waypoints if the GRF supports it (newstatsw.grf)
Thu, 04 May 2006 19:21:16 +0000 peter1138 (svn r4739) - Newstations: remove cargo type parameter of GetCustomStationRelocation() as we can determine it internally
Wed, 03 May 2006 21:19:21 +0000 peter1138 (svn r4723) - Newstations: add TileIndex parameter to station resolver.
Wed, 03 May 2006 20:35:41 +0000 peter1138 (svn r4719) - Newstations: instead of drawing nothing, fall back to the default sprite layout if a station layout specifies so.
Thu, 27 Apr 2006 18:28:56 +0000 belugas (svn r4593) CodeChange : Renamed spec (when using StationSpec) to statspec.
Wed, 26 Apr 2006 21:48:22 +0000 Darkvater (svn r4586) - Codechange: Recursive commands that rely on _error_message to handle success/failure can fail if a recursive call fails but doesn't set the error message, thus resulting in an old, possibly erroneous being used (see FS#130 prior to r4585). Now properly reset the global variable _error_message in these cases.
Tue, 25 Apr 2006 07:32:33 +0000 tron (svn r4572) Remove vehicle_leave_tile_proc
Sun, 23 Apr 2006 19:35:36 +0000 tron (svn r4554) Replace magic numbers by TILE_{HEIGHT,SIZE}
Sun, 23 Apr 2006 15:57:34 +0000 peter1138 (svn r4546) - NewGRF: add support for Action 0x05, type 0x04: replacement signal graphics. Thanks to Purno for supplying data to test
Sun, 23 Apr 2006 13:48:16 +0000 tron (svn r4541) Add a type for slopes and replace many magic numbers by the appropriate enums
Mon, 17 Apr 2006 19:09:30 +0000 celestar (svn r4461) -Codechange: Add and make use of map accessor functions for signal drawing. Includes some basic cleanup of the drawing functions
Sat, 15 Apr 2006 22:16:47 +0000 Darkvater (svn r4440) - Fix: Yoyo-effect of rail in desert/snow introduced by r4379. When a special groundtype below the track is encountered in the tileloop, always return even if groundtype hasn't changed.
Fri, 14 Apr 2006 16:28:24 +0000 peter1138 (svn r4415) Fix bug introduced in r4384 where drawing a default waypoint for the GUI
Wed, 12 Apr 2006 13:25:32 +0000 celestar (svn r4386) -Codechange: Add and make use of IsCustomWaypoint
Wed, 12 Apr 2006 12:50:40 +0000 celestar (svn r4384) -Codechange: rail drawing code
Wed, 12 Apr 2006 12:33:21 +0000 peter1138 (svn r4383) - Codechange: Remove extraneous code from 4354; no need to get RailTypeInfo when we already have it...
Wed, 12 Apr 2006 12:24:39 +0000 celestar (svn r4382) -Codechange: Make use of SetSignalType where appropriate
Wed, 12 Apr 2006 12:22:43 +0000 celestar (svn r4381) -Codechange: Forgot an occurence for rail ground types
Wed, 12 Apr 2006 12:12:51 +0000 celestar (svn r4380) -Codechange: Make use of GetTrackBits where appropriate
Wed, 12 Apr 2006 11:58:07 +0000 celestar (svn r4379) -Codechange: Add and make use of map accessor functions concerning rail ground types
Wed, 12 Apr 2006 09:36:27 +0000 celestar (svn r4378) -Add and make use of an accessor function two-way => one-way => one-way => two-way signal cycling
Wed, 12 Apr 2006 09:12:33 +0000 celestar (svn r4377) -Add and make use of a function that finds out whether a signal is an entry or and exit signal to a presignal block (as combos act as both)
Wed, 12 Apr 2006 08:28:03 +0000 celestar (svn r4376) -Codechange Renamed GetSignalState to GetSignalStateByTrackdir
Wed, 12 Apr 2006 08:06:08 +0000 celestar (svn r4375) -Codechange: Move the signal drawing bit to an own function and rename DrawSignalHelper to DrawSingleSignal
Tue, 11 Apr 2006 13:19:05 +0000 celestar (svn r4358) -Codechange: Don't use a TileInfo where a TileIndex will do
Tue, 11 Apr 2006 13:10:16 +0000 celestar (svn r4357) -Codechange: Moved global _signal_base_sprites into the only function where it is used and use a better array arrangement for it