waypoint.h
Thu, 21 Dec 2006 00:13:56 +0000 Darkvater (svn r7521) -Codechange: Rename UpdateAllWaypointCustomGraphics to AfterLoadWaypoints to be more conforming with other such functions.
Sun, 03 Dec 2006 17:27:43 +0000 matthijs (svn r7331) - Codechange: Rename all memory pool macro's and types to "old pool", so the new pool implementation can be committed alongside it.
Sat, 28 Oct 2006 11:59:10 +0000 tron (svn r6987) Use the pool macros for the Waypoint pool
Sat, 26 Aug 2006 16:46:32 +0000 truelight (svn r6143) -Codechange: DeleteWaypoint removes a waypoint from the pool
Sat, 26 Aug 2006 16:34:03 +0000 truelight (svn r6142) -Codechange: added WaypointID (sorry DV, couldn't splits it anymore)
Tue, 22 Aug 2006 18:15:17 +0000 truelight (svn r6053) -Codechange: renamed all IsXXXIndex to IsValidXXXID
Tue, 22 Aug 2006 15:33:35 +0000 truelight (svn r6047) -Codechange: FOR_ALL now _only_ loops valid items, and skips invalid ones
Tue, 15 Aug 2006 16:55:40 +0000 rubidium (svn r5919) -Cleanup: use the type Date when the variable really is a date
Mon, 19 Jun 2006 09:15:16 +0000 tron (svn r5313) Move IsRailWaypoint() to rail_map.h and remove unused enum
Tue, 09 May 2006 08:17:33 +0000 rubidium (svn r4788) - Codechange: RAILTYPE_{NORMAL,ELECTRIC,...} and RAIL_TYPE_{NORMAL,SIGNAL,...} have nearly the same name, rename RAIL_TYPE_* to RAIL_TILE_* of extra clarity
Sun, 26 Mar 2006 22:55:27 +0000 Darkvater (svn r4131) - CodeChange: Add proper semantics for StationID for such variables instead of using the general uint16-type. StationID was added for depots, waypoints and stations where necessary. We probably need to change GetDepot(), IsDepotIndex(), IsStationIndex(), GetWaypoint() and IsWaypointIndex() as well to use StationID.
Sun, 26 Mar 2006 22:41:56 +0000 Darkvater (svn r4130) - CodeChange: Add proper semantics for TownID for such variables instead of using the general uint16-type. We probably need to change GetTown() and IsTownIndex() as well to use TownID.
Fri, 17 Mar 2006 07:02:34 +0000 tron (svn r3913) Move declarations to rail_map.h so rail.h is dependent on rail_map.h and not the other way round
Thu, 05 Jan 2006 12:40:50 +0000 tron (svn r3365) Staticise 36 functions
Wed, 16 Nov 2005 22:20:15 +0000 peter1138 (svn r3212) - Waypoints/Depots: Store waypoint index in m2 for waypoints. This moves the ground type bits from m2 to m4 for waypoints and depots (leaving room for depot index in m2 in future), and moves the custom graphics ID to the waypoint struct.
Wed, 16 Nov 2005 14:41:01 +0000 truelight (svn r3210) -Codechange: use IsRailWaypoint where possible (instead of magicnumbers)
Sat, 12 Nov 2005 00:19:34 +0000 peter1138 (svn r3167) - NewGRF: Start moving custom station code to separate files.
Sun, 16 Oct 2005 09:13:04 +0000 tron (svn r3049) Replace byte/int/uint by RailType where appropriate
Sun, 31 Jul 2005 22:53:57 +0000 celestar (svn r2774) -Codechange: Removed TRACKTYPE_SPRITE_PITCH globally and replaced it by a member of RailtypeInfo
Sun, 24 Jul 2005 14:12:37 +0000 tron (svn r2701) Insert Id tags into all source files
Sun, 17 Jul 2005 20:14:58 +0000 tron (svn r2626) static, const, misc.
Fri, 24 Jun 2005 12:38:35 +0000 tron (svn r2483) Replace almost 500 "uint tile" (and variants) with "TileIndex tile"
Fri, 22 Apr 2005 05:41:09 +0000 tron (svn r2222) Check the parameters of Cmd{Insert,Delete,Modify,Skip}Order() and CmdRestoreOrderIndex():
Thu, 24 Mar 2005 17:03:37 +0000 truelight (svn r2046) -Codechange: moved all waypoint code to waypoint.c/waypoint.h