road_cmd.c
Wed, 04 Oct 2006 12:01:59 +0000 bjarni (svn r6637) -Codechange: merged all (vehicle type)EnterDepot into VehicleEnterDepot()
Tue, 26 Sep 2006 16:47:51 +0000 bjarni (svn r6513) -Codechange: unified the code to draw depot windows
Sat, 26 Aug 2006 14:44:55 +0000 truelight (svn r6141) -Codechange: introduced DepotID and used it as much as possible
Tue, 22 Aug 2006 18:15:17 +0000 truelight (svn r6053) -Codechange: renamed all IsXXXIndex to IsValidXXXID
Tue, 22 Aug 2006 14:38:37 +0000 rubidium (svn r6045) -Cleanup: align all table-like structures using spaces, i.e. whitespace fixes only except for a few comments to make them uniform for the whole enum/struct.
Thu, 10 Aug 2006 14:44:32 +0000 tron (svn r5833) -Feature: Allow building of (certain) rails, roads and bridge ramps on steep sloped tiles
Sun, 06 Aug 2006 18:36:36 +0000 tron (svn r5796) Use DrawTileSprites/DrawTileSeqStruct for road depot drawing data, too
Sun, 06 Aug 2006 16:32:49 +0000 tron (svn r5794) Pass the TileIndex plus x and y coordinates into GetSlopeZ_* instead of a TileInfo
Sat, 05 Aug 2006 16:57:39 +0000 tron (svn r5772) Road depots always have an player as owner, so remove an useless check
Thu, 03 Aug 2006 06:44:54 +0000 tron (svn r5723) - Move the declaration of DrawRoadDepotSprite() out of functions.h (but I'm not too happy with the new header)
Sat, 22 Jul 2006 08:59:52 +0000 tron (svn r5582) Add and use AxisToTrack{Bits,}()
Wed, 28 Jun 2006 06:10:20 +0000 tron (svn r5396) - Remove two fixed parameters
Tue, 27 Jun 2006 21:25:53 +0000 tron (svn r5391) Miscellaneous, mostly bracing and whitespace, nothing spectacular
Mon, 19 Jun 2006 20:13:50 +0000 tron (svn r5317) s/RGT_/ROADSIDE_/ and some minor changes
Mon, 19 Jun 2006 17:22:57 +0000 tron (svn r5315) -Fix: Prohibit altering a road tile while road works are in progress
Sat, 10 Jun 2006 08:37:41 +0000 tron (svn r5210) Many small changes which piled up: const, unsigned, variable scope, CSE for readability, DeMorgan, if cascades -> switch, whitespace, parentheses, bracing, misc.
Wed, 07 Jun 2006 19:35:21 +0000 tron (svn r5155) - Remove the bridge branch merge (revision r5070)
Fri, 02 Jun 2006 13:05:41 +0000 celestar (svn r5070) Merged the bridge branch
Sat, 27 May 2006 16:12:16 +0000 KUDr (svn r4987) Feature: Merged YAPF into trunk. Thanks to devs for continuous support and users for testing.
Sun, 21 May 2006 13:51:36 +0000 tron (svn r4940) Remove the dubious feature of remembering the last built depot. It serves no real purpose except causing confusion
Sat, 20 May 2006 18:03:22 +0000 tron (svn r4927) Replace 3 big ifs (which regard foundations) by a bit less confusing code
Tue, 09 May 2006 09:56:09 +0000 tron (svn r4790) Remove slope magic from EnsureNoVehicleZ() and rename it to EnsureNoVehicleOnGround() to make more clear what it does
Tue, 09 May 2006 08:25:31 +0000 rubidium (svn r4789) - Codechange: rename RoadType to RoadTileType and ROAD_{NORMAL,CROSSING,DEPOT} to ROAD_TILE_* for consistency
Tue, 09 May 2006 08:17:33 +0000 rubidium (svn r4788) - Codechange: RAILTYPE_{NORMAL,ELECTRIC,...} and RAIL_TYPE_{NORMAL,SIGNAL,...} have nearly the same name, rename RAIL_TYPE_* to RAIL_TILE_* of extra clarity
Thu, 27 Apr 2006 08:24:48 +0000 Darkvater (svn r4590) - Fix (r4585): warning: suggest parentheses around && within ||. Sorry
Wed, 26 Apr 2006 21:48:22 +0000 Darkvater (svn r4586) - Codechange: Recursive commands that rely on _error_message to handle success/failure can fail if a recursive call fails but doesn't set the error message, thus resulting in an old, possibly erroneous being used (see FS#130 prior to r4585). Now properly reset the global variable _error_message in these cases.
Wed, 26 Apr 2006 21:44:22 +0000 Darkvater (svn r4585) - Fix [FS#130] - Obscure road dragging bug. The road build command did not return the appropiate error message of invalid-slope when building road.
Tue, 25 Apr 2006 07:32:33 +0000 tron (svn r4572) Remove vehicle_leave_tile_proc
Sun, 23 Apr 2006 19:35:36 +0000 tron (svn r4554) Replace magic numbers by TILE_{HEIGHT,SIZE}
Sun, 23 Apr 2006 15:01:46 +0000 tron (svn r4544) Merge two almost identical string (STR_1[08]00_LAND_SLOPED_IN_WRONG_DIRECTION) - one just contains two redundant words
Sun, 23 Apr 2006 13:48:16 +0000 tron (svn r4541) Add a type for slopes and replace many magic numbers by the appropriate enums
Sat, 15 Apr 2006 20:07:42 +0000 Darkvater (svn r4435) - Fix: an assertion triggered when trying to remove a bridge with the remove-tool (r4348 surfaced this). In CmdRemoveRoad tiletype was not checked for ownership. Intorudce IsLevelCrossingTile() which checks if a tile is a crossing without knowing the type. Suggested by peter1138 and Tron.
Mon, 10 Apr 2006 07:15:58 +0000 tron (svn r4342) Change the first two parameters of commands - virtual pixel coordinates of the tile to operate on - to a TileIndex
Mon, 03 Apr 2006 18:11:42 +0000 Darkvater (svn r4265) - Fix: compile warning on VS2005 (parameter 2 different from declaration)
Mon, 03 Apr 2006 15:18:12 +0000 celestar (svn r4263) -Codechange: Road building no longer uses FindLandscapeHeight. Last occurence of FindLandscapeTile in the tile-specific functions gone. Thanks to Tron for doing lots of work in this direction
Mon, 03 Apr 2006 13:35:19 +0000 celestar (svn r4258) -Codechange: Add and make use of map accessors dealing with road ground types (including roadworks).
Mon, 03 Apr 2006 05:32:11 +0000 celestar (svn r4246) -Codechange. Replaced about 100 occurences of '16' by TILE_SIZE
Sun, 02 Apr 2006 12:49:18 +0000 tron (svn r4242) Pass TileIndex and slope to GetSlopeTileh_*() instead of TileInfo
Sun, 02 Apr 2006 07:05:35 +0000 tron (svn r4230) The road is asked for, not the rail. Undo part of r4164. (Pointed out by peter1138)
Fri, 31 Mar 2006 06:16:04 +0000 tron (svn r4187) Simplify the code for building/removing a piece of road a bit
Thu, 30 Mar 2006 19:16:44 +0000 belugas (svn r4181) CodeChange : Replaced [G/S]etMapExtraBits by [G/S]etTropicZone. Although it was an accessor, nor his usage nor the values were clear.
Thu, 30 Mar 2006 09:08:43 +0000 tron (svn r4164) Use acessor functions
Wed, 29 Mar 2006 21:10:42 +0000 belugas (svn r4160) CodeChange : Revert part of 4157, spotted by Tron
Wed, 29 Mar 2006 20:35:39 +0000 belugas (svn r4157) CodeChange : Keep on cleaning up Celestar's elrail merge
Wed, 29 Mar 2006 16:30:26 +0000 celestar (svn r4150) -Feature: Merged elrails into trunk. Thanks to Tron for lots of code and proofreading, thanks to peter1138 for another lot of code and ideas.
Sun, 26 Mar 2006 11:08:44 +0000 tron (svn r4111) Fix/Remove some stale comments
Fri, 24 Mar 2006 15:24:16 +0000 celestar (svn r4088) -Codechange: Introduce {Unb,B}arCrossing and IsCrossingBarred to put and get the status of a level crossing
Fri, 24 Mar 2006 12:00:24 +0000 tron (svn r4085) Add GetTown{Index,ByTile}() to get the town index resp. the town from a tile
Tue, 21 Mar 2006 22:06:32 +0000 tron (svn r4000) Rewrite GetSlope{Tileh,Z}_{Road,Track} in a less confusing way
Mon, 20 Mar 2006 13:34:01 +0000 tron (svn r3990) Remove another call to FindLandscapeHeight()
Sun, 19 Mar 2006 19:33:19 +0000 tron (svn r3986) Add [GS]etCrossingRoadOwner
Sun, 19 Mar 2006 17:15:33 +0000 tron (svn r3984) Add a function to get the road axis of a level crossing
Sun, 19 Mar 2006 13:48:08 +0000 tron (svn r3981) More work for the rail accessing functions and enums
Sun, 19 Mar 2006 12:06:12 +0000 tron (svn r3979) Move GetRailFoundation() to rail_map.h and use it and friends to get information about rail tiles
Fri, 17 Mar 2006 10:10:31 +0000 tron (svn r3916) Get/Set the rail type by [GS]etRailType{Crossing,OnBridge,}()
Thu, 16 Mar 2006 15:16:27 +0000 tron (svn r3907) Replace many bridge related direct map accesses with calls to shiny new functions and mark some strange constructs with XXX
Mon, 13 Mar 2006 12:55:20 +0000 tron (svn r3846) Add functions to set the type of stuff (clear, water, rail, road) under bridges
Fri, 10 Mar 2006 11:27:52 +0000 tron (svn r3812) Remove a pointless goto
Wed, 08 Mar 2006 15:29:23 +0000 tron (svn r3795) Add a function to request the orientation of a depot
Mon, 06 Mar 2006 13:11:08 +0000 tron (svn r3773) Shove some semantics down ottd's throat by replacing ints and magic numbers by enums and some related changes