Fri, 31 Mar 2006 17:02:00 +0000 peter1138 (svn r4210) - Use new {WEIGHT} string tag for all cargo quantity strings.
Fri, 31 Mar 2006 16:37:49 +0000 peter1138 (svn r4209) Remove unused strings
Fri, 31 Mar 2006 16:19:58 +0000 orudge (svn r4208) - Update OS/2 readme on trunk, sorry for all the commits!
Fri, 31 Mar 2006 16:11:51 +0000 peter1138 (svn r4206) - Add bridge_map.h and unmovable_map.h to MS VS project file
Fri, 31 Mar 2006 16:11:09 +0000 orudge (svn r4205) Whoops, forgot to add os_timer.c to project
Fri, 31 Mar 2006 16:01:59 +0000 orudge (svn r4204) - Get trunk compiling again on OS/2
Fri, 31 Mar 2006 15:34:22 +0000 orudge (svn r4203) - Fix compilation on mingw32 (stdint.h not included)
Fri, 31 Mar 2006 12:59:43 +0000 peter1138 (svn r4201) - Codechange: Do for _engine_info[] what we do for _*_vehicle_info[]; create and use a function to retrieve data, and ensure constness.
Fri, 31 Mar 2006 10:47:06 +0000 celestar (svn r4200) -Codechange: Make use of water map accessors when getting the Index of a Ship Depot. TODO: Store the depot index in the map
Fri, 31 Mar 2006 10:44:32 +0000 peter1138 (svn r4199) - Codechange: Use industry map accessors to get industry graphics type.
Fri, 31 Mar 2006 10:14:25 +0000 peter1138 (svn r4198) - NewGRF: Rename GetCallBackResult() to GetVehicleCallback(), as other types will exist later, and use separate parameters instead of bitshifting.
Fri, 31 Mar 2006 10:04:18 +0000 bjarni (svn r4197) reentered STATIC_ZLIB_PATH (removed in 4183) since it turned out that it's used after all
Fri, 31 Mar 2006 09:09:26 +0000 celestar (svn r4196) -Codechange: Add and make use of an accessor that modifies the size of the Company HQ
Fri, 31 Mar 2006 09:08:02 +0000 peter1138 (svn r4195) - Codechange: Initialize order variables to avoid a compiler warning. These are unused anyway... (smells of r3476-7, but not the same)
Fri, 31 Mar 2006 08:59:19 +0000 celestar (svn r4194) -Codechange: Renamed UpdatePlayerHouse to UpdateCompanyHQ because the rest of the code calls it Comapany HQ. Moved it to unmovable_cmd.c because CompanyHQ is an unmovable and has nothing to do with economy.
Fri, 31 Mar 2006 08:44:53 +0000 celestar (svn r4193) -Codechange: Add and make use of an accessor function to create company HQs
Fri, 31 Mar 2006 08:39:10 +0000 peter1138 (svn r4192) - Fix: In the depot, moving wagons from the end of a very long train to a short train where the short train was scrolled off the window would cause a game crash. (Thanks to SimonRC for reporting.)
Fri, 31 Mar 2006 08:35:05 +0000 Darkvater (svn r4191) - Codechange: Properly set newlines and id for os_timer.c
Fri, 31 Mar 2006 08:18:14 +0000 celestar (svn r4190) -Codechange: Add and make use of an accessor function to create houses
Fri, 31 Mar 2006 06:16:04 +0000 tron (svn r4187) Simplify the code for building/removing a piece of road a bit
Thu, 30 Mar 2006 20:14:06 +0000 bjarni (svn r4183) -Codechange: [Makefile]: removed MANUAL_CONFIG as it's not used anymore
Thu, 30 Mar 2006 19:16:44 +0000 belugas (svn r4181) CodeChange : Replaced [G/S]etMapExtraBits by [G/S]etTropicZone. Although it was an accessor, nor his usage nor the values were clear.
Thu, 30 Mar 2006 15:47:18 +0000 celestar (svn r4180) -Fix: Fixed an assert in the elrail drawing code due to passing of a wrong variable. I wish the compiler would warn about different enum types used...
Thu, 30 Mar 2006 15:06:49 +0000 celestar (svn r4179) -Codechange: Add and make use of an accessor that obtains the building type
Thu, 30 Mar 2006 13:12:36 +0000 celestar (svn r4178) -Fix: Draw catenary inside waypoints as well
Thu, 30 Mar 2006 13:06:16 +0000 celestar (svn r4177) -Fix: GetRailTrackBitsUniversal needs Trackbits, not Track. While at it, remove an unused variable
Thu, 30 Mar 2006 12:00:35 +0000 celestar (svn r4173) -Codechange: Use IsClearWaterTile for buoy construction
Thu, 30 Mar 2006 11:21:36 +0000 celestar (svn r4172) -Codechange: Added a few accessors to work with ShipDepots and Locks
Thu, 30 Mar 2006 11:11:35 +0000 celestar (svn r4171) -Codechange: Create map accessor functions for creating ship depots and locks. Make use of them
Thu, 30 Mar 2006 11:05:05 +0000 celestar (svn r4169) -Codechange: Removed an include which accidently slipped into a commit
Thu, 30 Mar 2006 10:53:31 +0000 celestar (svn r4168) -Fix: Fixed a typo in previous commit
Thu, 30 Mar 2006 09:29:01 +0000 tron (svn r4166) Sprinkle several map accessors with assert()s
Thu, 30 Mar 2006 09:26:17 +0000 celestar (svn r4165) -Do not use GetBridgeAxis on bridge ramps (request by Tron)
Thu, 30 Mar 2006 09:08:43 +0000 tron (svn r4164) Use acessor functions
Thu, 30 Mar 2006 00:48:45 +0000 belugas (svn r4163) CodeChange : Add missing file to MS Project and Workspace files
Wed, 29 Mar 2006 21:10:42 +0000 belugas (svn r4160) CodeChange : Revert part of 4157, spotted by Tron
Wed, 29 Mar 2006 20:57:17 +0000 bjarni (svn r4159) added missing comments about refitting in CmdCloneVehicle
Wed, 29 Mar 2006 20:41:15 +0000 bjarni (svn r4158) -Fix: [autoreplace] cost for refitting the new vehicle is now added to the cost animation. The player always paid for it, but it was not displayed until now
Wed, 29 Mar 2006 20:35:39 +0000 belugas (svn r4157) CodeChange : Keep on cleaning up Celestar's elrail merge
Wed, 29 Mar 2006 20:06:31 +0000 belugas (svn r4156) CodeChange : Little cleanup after Celestar's elrail merge
Wed, 29 Mar 2006 19:37:18 +0000 celestar (svn r4155) -Changed GetRoadStopByTile to use GetStationType and moved it. TODO: unify RS_TRUCK and STATION_TRUCK (same for bus)
Wed, 29 Mar 2006 19:03:47 +0000 celestar (svn r4154) -Moved MAX_BRIDGES in bridge.h and made it an enum. This makes two drops ...
Wed, 29 Mar 2006 19:00:56 +0000 celestar (svn r4153) -Codechange. Changed NPF_TILE_LENGTH into an enum and moved it out of variables.h. Just a drop in the bucket, but it is a start
Wed, 29 Mar 2006 16:59:33 +0000 belugas (svn r4152) properties set for elrail.c
Wed, 29 Mar 2006 16:56:38 +0000 bjarni (svn r4151) -Fix: [PowerPC] removed an incorrect uninitialized var used warning in os_timer
Wed, 29 Mar 2006 16:30:26 +0000 celestar (svn r4150) -Feature: Merged elrails into trunk. Thanks to Tron for lots of code and proofreading, thanks to peter1138 for another lot of code and ideas.
Wed, 29 Mar 2006 16:28:41 +0000 bjarni (svn r4149) -Codechange: [OSX] rewrite of how universal binaries are compiled
Wed, 29 Mar 2006 06:51:13 +0000 celestar (svn r4143) -[FS#86]: Fixed and obi-wan error in station_map.h that would lead to assertions in the airport handling (of international airports)
Tue, 28 Mar 2006 21:51:14 +0000 Darkvater (svn r4142) - Fix [FS#74]: Incorrectly loaded settings from the config file when the signed uint32 variable would be negative.
Mon, 27 Mar 2006 14:28:56 +0000 belugas (svn r4136) CodeChange : Revert part of r4092 (as spotted by Tron) and clean-up a little further
Mon, 27 Mar 2006 06:18:02 +0000 tron (svn r4134) Revert part of r4133: Replacing a byte which gets written to savegames by an enum is a very bad idea
Sun, 26 Mar 2006 22:58:11 +0000 Darkvater (svn r4133) - Some miscellaneous changes (unconverted TownID in function definition, Owner instead of byte, remove obsolete member and compare waypoint index with 0 not STR_NULL)
Sun, 26 Mar 2006 22:56:58 +0000 Darkvater (svn r4132) - Missed 3 CargoID's
Sun, 26 Mar 2006 22:55:27 +0000 Darkvater (svn r4131) - CodeChange: Add proper semantics for StationID for such variables instead of using the general uint16-type. StationID was added for depots, waypoints and stations where necessary. We probably need to change GetDepot(), IsDepotIndex(), IsStationIndex(), GetWaypoint() and IsWaypointIndex() as well to use StationID.
Sun, 26 Mar 2006 22:41:56 +0000 Darkvater (svn r4130) - CodeChange: Add proper semantics for TownID for such variables instead of using the general uint16-type. We probably need to change GetTown() and IsTownIndex() as well to use TownID.
Sun, 26 Mar 2006 22:25:29 +0000 Darkvater (svn r4129) - CodeChange: Add proper bool type for is_ai as well...it is a bool type.
Sun, 26 Mar 2006 22:23:32 +0000 Darkvater (svn r4128) - CodeChange: Add proper semantics for CargoID for such variables instead of using the general byte-type.
Sun, 26 Mar 2006 22:02:11 +0000 peter1138 (svn r4127) - Update English language file to use tags for the new unit system.
Sun, 26 Mar 2006 21:50:57 +0000 peter1138 (svn r4126) - Feature: A new multi-lingual multi-measuring-unit system:
Sun, 26 Mar 2006 21:15:09 +0000 Darkvater (svn r4125) - Feature: Add a general TIC() TOC() mechanism using rdtsc or something similar on non-i386 architectures to performance-tune (critical) code. Some systems are probably missing, but those can be added later.