industry_cmd.c
Fri, 14 Apr 2006 01:54:07 +0000 belugas (svn r4411) CodeChange : Define and use some Gfx for both stations and industries. More are still to come
Wed, 12 Apr 2006 18:10:54 +0000 belugas (svn r4399) CodeChange : Add and make use of [G|S]etIndustryAnimationLoop accessors.
Mon, 10 Apr 2006 21:00:56 +0000 belugas (svn r4350) CodeChange : Add and use accessors [G|S]etIndustrype. Define and use IndustryGfx type instead of uint
Mon, 10 Apr 2006 16:20:47 +0000 belugas (svn r4347) CodeChange : Renamed IndustryType to IndustryLifeType. Cleanup step toward bringing accessors [G|S]etIndustrype
Mon, 10 Apr 2006 15:09:56 +0000 belugas (svn r4346) CodeChange : Add and Use Accessors to Industry's Stage and Counter construction. Removed last direct map access from Disaster_cmd.c as well. Based on work from Rubidium in tfc_newmap
Mon, 10 Apr 2006 14:27:26 +0000 celestar (svn r4345) -Codechange: Similar to airport tiles, rename _industry_map5_ arrays to _industry_sections
Mon, 10 Apr 2006 07:15:58 +0000 tron (svn r4342) Change the first two parameters of commands - virtual pixel coordinates of the tile to operate on - to a TileIndex
Tue, 04 Apr 2006 21:35:13 +0000 tron (svn r4279) s/\<CL_/CLEAR_/
Tue, 04 Apr 2006 06:04:54 +0000 tron (svn r4270) Rename some bogus map5 to gfx
Mon, 03 Apr 2006 09:07:21 +0000 celestar (svn r4249) -Codechange: Replace more occurences of 16 by TILE_SIZE and of 8 by TILE_HEIGHT. Reverted one change from the previous commit because it was faulty
Mon, 03 Apr 2006 05:32:11 +0000 celestar (svn r4246) -Codechange. Replaced about 100 occurences of '16' by TILE_SIZE
Sun, 02 Apr 2006 12:49:18 +0000 tron (svn r4242) Pass TileIndex and slope to GetSlopeTileh_*() instead of TileInfo
Thu, 30 Mar 2006 19:16:44 +0000 belugas (svn r4181) CodeChange : Replaced [G/S]etMapExtraBits by [G/S]etTropicZone. Although it was an accessor, nor his usage nor the values were clear.
Sun, 26 Mar 2006 22:23:32 +0000 Darkvater (svn r4128) - CodeChange: Add proper semantics for CargoID for such variables instead of using the general byte-type.
Sun, 26 Mar 2006 19:20:15 +0000 tron (svn r4120) Use the new station functions where appropriate
Sat, 25 Mar 2006 10:38:28 +0000 tron (svn r4108) Add [GS]etIndustryGfx()
Fri, 24 Mar 2006 18:16:39 +0000 belugas (svn r4092) CodeChange : Named sprites instead of magic numbers plus create/use helper macro/enum for recoloring scheme
Fri, 24 Mar 2006 13:46:45 +0000 tron (svn r4087) Add IsIndustryCompleted() to check if a industry tile is fully built
Fri, 24 Mar 2006 13:31:17 +0000 tron (svn r4086) Add MakeIndustry()
Fri, 24 Mar 2006 08:00:45 +0000 tron (svn r4077) Add GetIndustry{Index,ByTile}() to get the industry index resp. the industry from a tile
Wed, 22 Mar 2006 19:04:04 +0000 tron (svn r4027) Remove another call to FindLandscapeHeightByTile()
Wed, 22 Mar 2006 08:48:50 +0000 tron (svn r4007) Add a function to make a farm field tile
Tue, 21 Mar 2006 23:22:21 +0000 belugas (svn r4004) -CodeChange : Renaming sprites and functions
Tue, 21 Mar 2006 20:02:05 +0000 tron (svn r3996) -Fix: Slope and height information returned for some tile types is wrong
Thu, 16 Mar 2006 00:20:33 +0000 Darkvater (svn r3895) - Add proper SLE(G)_CONDNULL macros for the empty space reservation in savegames and update where used
Thu, 09 Mar 2006 20:37:51 +0000 peter1138 (svn r3805) - [FS#62] Fix doxygen comments to refer to the correct parameter. (sulai)
Wed, 08 Mar 2006 06:55:33 +0000 tron (svn r3783) Replace further ints and magic numbers by Direction, DiagDirection and friends
Sun, 05 Mar 2006 10:19:33 +0000 tron (svn r3763) Adapt to the new 'map accessors go in foo_map.h'-scheme
Tue, 28 Feb 2006 06:14:42 +0000 tron (svn r3683) Get rid of another FindLandscapeHeight()
Mon, 20 Feb 2006 19:43:26 +0000 Darkvater (svn r3627) - Change all hardcoded 255 max-saveload versions with the define SL_MAX_VERSION
Sun, 05 Feb 2006 11:54:25 +0000 tron (svn r3554) Add accessors for the field type and fences of clear tiles
Wed, 01 Feb 2006 15:31:21 +0000 tron (svn r3514) -Codechange: Replace direct fiddling of bits for the ground type and density of clear tiles with symbolic names and accessors.
Wed, 01 Feb 2006 07:36:15 +0000 tron (svn r3511) More whitespace ([FS#46] by Rubidium)
Sun, 22 Jan 2006 09:52:20 +0000 peter1138 (svn r3416) - Fix: Disallow building an oil rig above sea level.
Thu, 05 Jan 2006 12:40:50 +0000 tron (svn r3365) Staticise 36 functions
Sat, 10 Dec 2005 12:05:39 +0000 peter1138 (svn r3282) - Codechange: Replace tests against CMD_ERROR with CmdFailed()
Wed, 16 Nov 2005 13:11:28 +0000 tron (svn r3205) Some more uses for GB/SB
Wed, 16 Nov 2005 11:55:06 +0000 tron (svn r3195) Use bitfields instead of explicit shifting/masking
Mon, 14 Nov 2005 19:48:04 +0000 tron (svn r3181) -Bracing
Mon, 14 Nov 2005 15:22:12 +0000 tron (svn r3180) Replace some magic numbers by symbolic names
Mon, 14 Nov 2005 09:21:05 +0000 tron (svn r3179) - RandomRange() and RandomTile() instead of home brewed versions
Sun, 13 Nov 2005 13:43:55 +0000 tron (svn r3172) static, const
Fri, 04 Nov 2005 16:12:48 +0000 tron (svn r3135) Use symbolic names in the tables, which hold the information about accepted goods of industry tiles, instead of magic numbers
Sun, 23 Oct 2005 13:04:44 +0000 tron (svn r3078) Some more stuff, which piled up:
Sat, 22 Oct 2005 06:39:32 +0000 tron (svn r3077) static, const, bracing, indentation, 0 -> '\0'/NULL, typos in comments, excess empty lines, minor other changes
Wed, 19 Oct 2005 14:49:46 +0000 tron (svn r3066) Constify the parameter of GetSlopeZ_*()
Wed, 19 Oct 2005 06:46:41 +0000 tron (svn r3064) Replace some numbers by sprite names
Fri, 07 Oct 2005 07:35:15 +0000 tron (svn r3024) -Codechange: Another batch of replacements of int/uint/int16/byte/-1 with proper types and constants
Wed, 05 Oct 2005 07:20:26 +0000 tron (svn r3019) -Codechange: Replace explicit shifting/anding/oring with GB and SB
Wed, 05 Oct 2005 04:00:39 +0000 peter1138 (svn r3018) -Fix: Fixed industry colour issue introduced in r3010.
Mon, 03 Oct 2005 21:20:01 +0000 tron (svn r3010) Get rid of quite some dubious casts, either by using GB(), proper types or just removing them
Wed, 28 Sep 2005 19:35:36 +0000 tron (svn r2995) Replace 0xFF/0xFFFF with CT_INVALID/OWNER_SPECTATOR/INVALID_STATION where appropriate
Sun, 18 Sep 2005 20:56:44 +0000 Darkvater (svn r2962) - const correctness for all Get* functions and most Draw* functions that don't change their pointer parameters
Tue, 23 Aug 2005 18:47:04 +0000 tron (svn r2886) Rename the "owner" attribute to "m1", because when it stores an owner it is accessed by [GS]etOwner anyway and when it doesn't store an owner, but arbitrary data, accessing a field called "owner" is confusing.
Mon, 01 Aug 2005 13:01:14 +0000 tron (svn r2780) Remove some more unused strings and make the use of a few strings more explicit
Sun, 24 Jul 2005 15:56:31 +0000 celestar (svn r2702) -Codechange: Cleaned up the sprite code and replaced many magic numbers
Sun, 24 Jul 2005 14:12:37 +0000 tron (svn r2701) Insert Id tags into all source files
Fri, 22 Jul 2005 07:02:20 +0000 tron (svn r2673) Include functions.h directly, not globally via openttd.h
Thu, 21 Jul 2005 22:15:02 +0000 tron (svn r2669) Shuffle some more stuff around to reduce dependencies
Thu, 21 Jul 2005 06:31:02 +0000 tron (svn r2660) Get rid of some more shifting/anding/casting