Tue, 29 Aug 2006 17:41:13 +0000 bjarni (svn r6215) -Codechange: [vehicle list windows] unified Player(vehicle)WndProc into PlayerVehWndProc
Tue, 29 Aug 2006 14:45:39 +0000 bjarni (svn r6213) -Fix: Calatan town names was only prefix OR the rest of the string, never both (nars)
Tue, 29 Aug 2006 06:50:47 +0000 tron (svn r6212) Remove dependency on window.h from station.h
Tue, 29 Aug 2006 06:43:22 +0000 tron (svn r6211) Commit file forgotten in r6210
Tue, 29 Aug 2006 06:39:00 +0000 tron (svn r6210) Remove FR_NOBORDER, because it is exclusivly used in conjunction with FR_TRANSPARENT
Tue, 29 Aug 2006 06:07:57 +0000 tron (svn r6209) Move DrawFrameRect() out of gfx.[ch], because it uses data (_color_list) which the renderer shouldn't have know about
Tue, 29 Aug 2006 06:03:26 +0000 tron (svn r6208) Reduce the number of induction variables for clarity
Tue, 29 Aug 2006 00:17:47 +0000 belugas (svn r6205) -CodeChange : use a switch case instead of a cascade of if
Mon, 28 Aug 2006 18:53:03 +0000 rubidium (svn r6204) -Cleanup: replace non-indentation with spaces; like '}<TAB>else {' -> '} else {', tabs between code and comment, etc.
Mon, 28 Aug 2006 12:57:33 +0000 miham (svn r6197) WebTranslator2 update to 2006-08-28 14:57:10
Mon, 28 Aug 2006 10:14:37 +0000 rubidium (svn r6195) -Codechange: do not use '//' in '/* ... */' style comments and '/*' or '*/' in '//' style comments.
Mon, 28 Aug 2006 09:13:33 +0000 rubidium (svn r6186) -Fix [FS#309]: add an override system to the dynamically determined size of steps for numeric patch settings in the 'Configure patches' GUI.
Mon, 28 Aug 2006 08:44:13 +0000 miham (svn r6185) WebTranslator2 update to 2006-08-28 10:43:48
Mon, 28 Aug 2006 07:33:51 +0000 tron (svn r6184) Remove the unused (because it was NULL in all callers) second parameter of FillDrawPixelInfo() and simplify some expressions
Mon, 28 Aug 2006 06:21:48 +0000 tron (svn r6183) Move GetDrawStringPlayerColor() out of gfx.[ch]
Mon, 28 Aug 2006 06:18:35 +0000 bjarni (svn r6182) -Code cleanup: replaced one (1 << 8) with SHARE_FLAG (missed in r6167)
Mon, 28 Aug 2006 06:13:16 +0000 bjarni (svn r6181) -Fix r6161: The list of vehicles using a certain station got a bit of display code mixed up with the list of vehicles with shared orders (nycom)
Mon, 28 Aug 2006 06:05:04 +0000 tron (svn r6180) Use a switch instead of function pointers to choose the blitter
Sun, 27 Aug 2006 22:08:40 +0000 glx (svn r6179) - Silence the old npf warnings
Sun, 27 Aug 2006 21:20:29 +0000 truelight (svn r6178) -Fix r5886: only setting ->money64 isn't enough, as some routines still use ->player_money.
Sun, 27 Aug 2006 20:30:10 +0000 miham (svn r6177) WebTranslator2 update to 2006-08-27 22:29:43
Sun, 27 Aug 2006 15:26:58 +0000 truelight (svn r6176) -Fix r6052: I assumed an typedefd enum would be an uint8, which is a really stupid thing to assume.
Sun, 27 Aug 2006 15:21:10 +0000 miham (svn r6175) WebTranslator2 update to 2006-08-27 17:18:26
Sun, 27 Aug 2006 14:28:23 +0000 KUDr (svn r6174) -Cleanup: [YAPF] some SDT_CONDVARs replaced by SDT_VARs since they are not saved in savegame (Darkvater)
Sun, 27 Aug 2006 12:09:06 +0000 miham (svn r6173) WebTranslator2 update to 2006-08-27 14:08:35
Sun, 27 Aug 2006 10:49:43 +0000 Darkvater (svn r6170) -Feature: save max_companies/clients/spectators in the config file.
Sun, 27 Aug 2006 10:04:33 +0000 Darkvater (svn r6169) -Codechange: Use GetString() instead of GetStringWithArgs() which should be
Sun, 27 Aug 2006 10:04:02 +0000 bjarni (svn r6168) -Code cleanup r6161: removed a newline and added a tab. Thanks TrueLight
Sun, 27 Aug 2006 09:55:54 +0000 bjarni (svn r6167) -Code cleanup r6161: replaced some uint16 with OrderID and (1 << 8) with SHARE_FLAG
Sun, 27 Aug 2006 09:50:43 +0000 KUDr (svn r6166) -Fix: [YAPF] fixes one very improbable assert when adding startup node that already exists in the open-list (thanks Panzerfather)
Sun, 27 Aug 2006 09:28:52 +0000 bjarni (svn r6165) -Feature: control click Goto Depot will now make the vehicle service
Sun, 27 Aug 2006 07:23:46 +0000 KUDr (svn r6164) -Fix [YAPF]: Road vehicles preferring bends - added yapf.road_curve_penalty setting with default value 100 (=YAPF_TILE_LENGTH) that is saved only in MP games (mart3p)
Sun, 27 Aug 2006 07:04:14 +0000 KUDr (svn r6163) -Codechange: distance rounded up (correction of r6162)
Sun, 27 Aug 2006 06:52:25 +0000 KUDr (svn r6162) -Fix: Multistop problem caused by incorrect distance returned by YapfRoadVehDistanceToTile() (by mart3p)
Sat, 26 Aug 2006 22:28:40 +0000 bjarni (svn r6161) -Feature: List of vehicles with the same shared orders
Sat, 26 Aug 2006 22:24:32 +0000 KUDr (svn r6160) -Fix [ 1519167 ] Bus trying to service in depot of other company (mart3p)
Sat, 26 Aug 2006 21:54:04 +0000 Darkvater (svn r6159) -Fix: FindClosestTrainDepot hardly ever found a depot with NPF off due to absence of distance-normalization (Rojer)
Sat, 26 Aug 2006 20:54:30 +0000 Darkvater (svn r6158) -Revert r6139 as that breaks strings with cases. Thanks michi_cc
Sat, 26 Aug 2006 20:09:25 +0000 truelight (svn r6157) -Codechange: DeleteVehicle removes a vehicle from the pool
Sat, 26 Aug 2006 19:51:49 +0000 truelight (svn r6156) -Codechange: DeleteIndustry removes an industry from the pool
Sat, 26 Aug 2006 19:47:13 +0000 truelight (svn r6155) -Codechange: split Destroy routine from SpriteGroupPoolCleanBlock
Sat, 26 Aug 2006 19:40:40 +0000 truelight (svn r6154) -Cleanup: ordered the IDs that have to do with pools from the others
Sat, 26 Aug 2006 19:29:35 +0000 truelight (svn r6153) -Codechange: DeleteSign removes a sign from the pool
Sat, 26 Aug 2006 19:18:50 +0000 truelight (svn r6152) -Codechange: renamed GetNumRoadStops to GetNumRoadStopsInStation as it reflects its function more
Sat, 26 Aug 2006 19:14:02 +0000 truelight (svn r6151) -Codechange: DeleteStation/DeleteRoadStop removes a station/RoadStop from the pool
Sat, 26 Aug 2006 18:27:15 +0000 truelight (svn r6150) -Codechange: introduced and used RoadStopID where needed
Sat, 26 Aug 2006 18:05:05 +0000 truelight (svn r6149) -Codechange: DeleteTown removes a town from the pool
Sat, 26 Aug 2006 17:34:48 +0000 truelight (svn r6148) -Fix r6146: mostly it is useful to declare a variable in the function you use it (tnx Tron)
Sat, 26 Aug 2006 17:31:57 +0000 truelight (svn r6147) -Fix: I don't know how to write Destination :(
Sat, 26 Aug 2006 17:31:47 +0000 truelight (svn r6146) -Fix: MSVC doesn't know how to cast to an union.. so fix it via an indirect (and btw the old) way
Sat, 26 Aug 2006 17:16:51 +0000 truelight (svn r6145) -Codechange: added OrderID to indicate Order indexes out of the pool
Sat, 26 Aug 2006 17:12:24 +0000 truelight (svn r6144) -Codechange: renamed OrderID to VehicleOrderID, because it had nothing to do
Sat, 26 Aug 2006 16:46:32 +0000 truelight (svn r6143) -Codechange: DeleteWaypoint removes a waypoint from the pool
Sat, 26 Aug 2006 16:34:03 +0000 truelight (svn r6142) -Codechange: added WaypointID (sorry DV, couldn't splits it anymore)
Sat, 26 Aug 2006 14:44:55 +0000 truelight (svn r6141) -Codechange: introduced DepotID and used it as much as possible
Sat, 26 Aug 2006 14:41:16 +0000 Darkvater (svn r6140) -Codechange: fix the comment of _shift_pressed. It doesn't react to ALT, but to SHIFT.
Sat, 26 Aug 2006 14:39:05 +0000 Darkvater (svn r6139) -Codechange: strings are StringID. This should be changed in strings.h as well, but you would need to include openttd.h and that opens a whole new can of worms.
Sat, 26 Aug 2006 14:36:19 +0000 Darkvater (svn r6138) - Remove stdafx.c since we do not use it.
Sat, 26 Aug 2006 14:22:54 +0000 truelight (svn r6137) -Codechange: some very minor cleanups:
Sat, 26 Aug 2006 11:06:54 +0000 truelight (svn r6136) -Fix: _cur_year wasn't converting when reading pre-31 savegames, causing nasty desyncs